タグ別アーカイブ: インストールエラー

Cent OS6 apache2.4.1のインストールエラー


最新版のapache2.4.1はnginxより早い?!っと言った社内の話題に乗っかって

自分のテスト環境をバージョンアップするも

いろいろなエラーがでててんやわんやです。


まず、必ず発生するのはapr関係のエラーです。外部のモジュールになった?aprはバージョンの指定とともに

エラーを出力してきます。

これは、最新のバージョンをコンパイルしてインストールすればすぐ解決します。


# wget http://ftp.riken.jp/net/apache//apr/apr-1.4.6.tar.gz

./configure
make
make install


# wget http://ftp.riken.jp/net/apache//apr/apr-util-1.4.1.tar.gz

./configure \
–with-apr=/usr/local/apr/


後は、開発のライブラリーが不足しているといろいろとconfig時にエラーがでます。

まあ、この辺はapache2.4.1で無くてもでてきます。


configure: error: pcre-config for libpcre not found. PCRE is required and available from http://pcre.org/

# yum -y install pcre-devel


無事に最新版をインストール完了。httpd.confの設定ファイルはそのまま利用できない?互換性が無い?