HOME >  システム開発 > PHP5.4.0 imagick.so imagemagick コンパイルエラー

PHP5.4.0 imagick.so imagemagick コンパイルエラー


PECL Package 最新版

PECL Package 最新版


PHPでimagemagickを扱う際は、peclのimagickを利用しているのですが

どうやらPHP5.4.0では、最新のimagick(3.1.0RC1)でないとコンパイル時にエラーになってしまいます。

3.1.0RC1
– Fixed PECL Bug #22722
– Fixed possible memory leaks in error scenarios
– Added PHP 5.4 support


# pecl install imagick

では、エラーになってしまうので、別途最新版をダウンロード指定して導入します。

http://pecl.php.net/package/imagick

何かと最新版を利用すると、ところどころに不具合が見るかりますね。

apache2.4.1 + php5.4.0

一通り不具合が解消され現在は安定動作をし続けています。

apache2.4.1は大幅に機能が追加されているので、今から勉強必須です。